概要

このプログラムは、株式会社 東浦技研　長坂 正樹の監修により開発された
マシニングセンターの機械語を自動生成するものです。
２８種類の加工パターンはリスト選択で行い、必要項目は自動的に表示され、
その部分に必要なデータを入力すれば、センタードリル、下穴ドリルなどは
入力しなくても自動生成します。また、入力できない数値は、出来るだけ
警告を出す様にしています。

機種に依る翻訳言語の違いにも対応しています。
被加工物材質設定で、機種別翻訳設定が出来ます。
９種類の選択が出来、エンドミルその他で設定された情報が自動的に設定されます。
面取りカッターについては、面取りカッター設定で設定した情報が、
エンドミルその他で設定された面取りカッター番号に拠って、翻訳時に
引き継がれます。

過去に使用したツール番号データも有効利用できる様になっています。
加工パターンデータファイルは、フォルダー[ PatternData ]、
ツール番号データは[ ToolData ]、生成された機械語は、[ OutPutData ]に
保存される様にして有りますが、これはあくまで、
デフォルト状態の場合で、ファイル操作ダイアログボックスの部分で
変更すれば何処にでも保存、読み出しは可能です。

[注意]、生成された機械語データファイルはテキスト形式ですので
        メモ帳などで見ることも編集することも出来ますが、
        それ以外のファイルは特殊形式になっていますので、
        見ても意味不明な表示がされます。
        見るだけなら問題は起こりませんが、書き込みをしてしまうと
        内容が破壊されます。特に、自動バックアップ指定されている
        ワープロで操作すると、知らない内に書き込みされてしまいますので
        注意が必要です。
        破壊されたファイルは元に戻す事は出来ませんので注意が必要です。
        特に、[Machine.ini]ファイルには、加工条件データが入っています
        壊してしまうと、プログラムが立ち上がらなくなります。
        その時の処置方法はエラーについてに記述して有ります。

        このプログラムは、コピー防止処理が施されていますので、
        ファイルをコピーしただけでは起動しません。
        特に、[ Protect.key ]ファイルは重要ですので
        移動、削除、編集などはしないでください。


使用方法

（１）プログラムを起動したら、新規作成の場合は、データ入力許可をしてください。
      パスワードが設定されている場合はパスワードを入力する必要があります。

（２）工順及び材質設定を選択し、被加工物材質、座標系、板厚を設定してください。
      これが設定されていないと、後のデータ入力が出来ません。

（３）加工方選択に入力窓を合わせリターンキーを押すとパターンリストが
      表示されます。
      加工したいものを選択しリターンキーを押します。

（４）入力項目にデータを入れます。この場合、右横矢印キーを押すと項目部分に
      入力窓が移動します、またはマウスの左ボタンで入力したい部分をクリック
      すれば位置選択が出来ます。直接数値を入力した場合は、数値が、
      ただちに入ります。リターンキーを押した場合は、
      既に入力されている数値が編集窓に反映されます。
      決定は、リターンキーを押してください。
      深さ回数と、径回数は、未入力の場合、自動的に１回に解釈されます。
      入力項目に応じて文字入力制限をしています。負の数値を入れてはいけない
      部分では(ー)記号は入りません。
      標準タップなどは、内部リストに無い径の数値は入りません。
      その他、深さ、工具径で不自然な数値を入れた場合は警告が出ます。
      穴開け深さを入れた後に加工面高さを変更した場合は警告は出ませんが、
      ツール検索で開かれる処理情報表示ウインドウに警告が表示されます。
      Ｄ補正番号、Ｐ(Ｏ) サブ番号、Ｔツール番号は、Ｄ、Ｐ、Ｔの頭文字が
      自動的に付けられますので、数字のみを入力してください。

  注意事項、データの翻訳は、パターン表番号１から最初に見つかった
            加工法選択（未入力）までです。
            その後にデータが有っても翻訳対象にはなりません。

（５）使用ツール番号の設定をしてください。
      方法はそれぞれの説明を参照してください。

（６）作業工程順表示及び変更を行ってください。
      方法はそれぞれの説明を参照してください。

（７）ファイルを保存し、次は翻訳を実行してください。
      リスト表示と、ファイルに出力の２通りがありますが、いずれも、
      その都度翻訳しながら出力します。
      翻訳データそのものは、ファイルに出力されたもの以外は、保存しません。
      過去のデータを読み込んで、翻訳出力した場合もその都度翻訳し直します。

  注意事項、（５）以降を行った後に、被加工物材質、板厚、加工パターン、
            入力項目、加工条件を変更すると、ツール番号データ、作業工程順データは
            全てクリアされます。（５）番からやり直さなければなりません。
            但し、使った工具のツール番号は記憶していますので自動的に
            割り付けられます。

            例えば、エンドミルで窪みを作った中に面取り付き穴開けを指示した場合、
            穴径が７ｍｍを超える場合は、面取りカッターが自動的に用意されます。
            面取りカッターの径は１８ｍｍ有りますので、縁と穴の中心が９ｍｍ以下
            の場合は、縁とカッターが干渉してしまいます。
            干渉するかどうかは、加工パターンデータからは判断できませんので、
            自己責任で運用してください。
            但し、穴開けのみをさせたい場合は、作業工程順表示及び変更で面取り
            カッター作業だけを削除することも出来ます。

新規でない場合は、ファイルを読み込んで機械語を出力することになりますが、
（５）より前で、或いは、データの変更をした後（５）を行わずにファイルを
保存した場合は、翻訳すべきデータは存在しませんので、（５）以降を行ってから
翻訳する必要があります。
データの保存は、編集モードであれば何時でも出来ます。
データの読み出しと翻訳はデータさえ有れば何時でも出来ます。


基本操作法

（１）新規データ作成の場合は、データ入力許可を許可にする。
      この場合パスワードが設定されている場合は、パスワードの入力が必要。

（２）工順及び材質設定ー＞被加工物材質、座標系、板厚、Ｏ番号設定をクリック。
      ダイアログ内の項目を全て設定する。数値設定は上下ボタンでも直接数値入力
      でも良いが、直接入力した場合は数値制限を越えると、右に真理値が表示される。

（３）加工パターン表データを入力する。入れてはいけない数値などは警告を表示する。
      サブ番号の様に頭に文字の付く数値の場合は、数値だけを入力すれば頭文字は
      自動的に付加される。

（４）加工パターン表データ入力が終わったら、工順及び材質設定ー＞使用ツール番号設定
      をクリック。ツール番号表示ウインドウが現れる。編集ボタンを押す。
      ボタン表示が「表示」に変わる。
      ツール検索ボタンを押す。使用されたツールが表示され、加工順データが作成される。
      Ｔ番号を入力する。この場合も数値のみを入れる。
      全てのツールに番号を入力したら、終了ボタンを押す。
      正常に設定されている場合は、ツール番号データファイルを作成しますか、
      と言うメッセージが表示されます。マシニング装置のツール交換を
      あまりしない場合は、これを作成しておけば、次からは、このデータで
      ツール番号を割り付け出来る様になります。
      方法はツール番号自動割り付けで行います。詳しくはそれらの説明を見てください。

（５）次は、工順及び材質設定ー＞作業工程順表示及び変更をクリック
      実際に使用されるツールとデータが表示されます。このままで翻訳することも
      出来ますが、加工パターン順に作業され、ツール交換が頻繁に行われます。
      高率良く動かすためには、加工順序最適化をします。編集ボタンを押し
      編集モードにする
      加工パターンでは入力しなかったツール（自動生成）されたもので、
      作業させると都合の悪い物は、ここで削除できます。その後、
      加工順序最適化ボタンを押すと、加工順序が変更されます。
      良ければ、終了ボタンを押す。

（６）作成された加工データを保存する。ファイルー＞上書き保存か、
      名前を付けて保存をする。
      ５番まで作業をした後に、加工パターン、板厚、材質、加工条件などを変更すると、
      ツール番号データと、加工パターン順データは消去されますので、
      加工パターン表データだけが保存されることになります。

（７）翻訳データを作成するには、ファイルー＞加工プログラム出力をクリック
      翻訳状態表示ウインドウがでます。翻訳開始ボタンを押すと翻訳結果が表示されます。
      ファイル出力で、テキスト形式のファイルが出力されます。
      印刷では、結果が印刷されます。翻訳結果は、加工パターンデータファイルには
      保存されません。その都度翻訳します。

（８）新規データで無い場合は、ファイルー＞ファイルを開くをクリック
      何も変更が無ければ、７番から実行でＯＫです。
      データ変更をした場合は、４番からやり直しをしなければなりません。
      この場合も、ツール番号データファイルが使えます。


マウスとキーボード操作

殆どの操作は、他のウインドウプログラムと同じですが、加工パターン表の
編集はメニューで行います。他の画面ではマウスを右クリックすると
フローティングメニューを表示しますので、そこで操作してください。
加工パターン表で加工パターンは選択リストボックス方式になっています。
編集モード時にリターンキーを押すと選択できます。
決定は、リターンキーを押す。
加工パターンを選択後リターンキーを押すと、自動的に入力項目の
最初に移動します。
入力項目の入力位置を移動させるには、左右矢印キーを押すか、
マウスで入力したい部分をクリックする。
入力項目の最後のサブ番号入力後リターンキーを押すと、
自動的に次のパターン選択に移動します。
加工パターン表縦スクロールバーは、２０項目分を参照できるのみです。
それ以降を見たい場合は上下矢印キーでデータ番号を移動します。
これは、編集時も同じです。マウスの右クリックでページ送りメニューを
表示しますので、これで移動しても良いです。
他のウインドウは、スクロールバーとデータ番号送りが連動しています。
ホームキーとエンドキーは、加工パターン入力ウインドウの編集モードでは、
押すと、その行の初め（加工パターン選択）と終わり（サブ番号）に移動します。
他のウインドウでは、データの初めと終わり、或いは、行の左と右に移動します。
キーボード操作は、メニュー選択の場合、メニュー項目の右にあるアルファベット
例えば、ファイルの場合Ｆの字があります。
Ａｌｔキーを押すとメニュー選択状態になります。
または、Ａｌｔキーを押しながらＦキーを押すとファイル以下のメニューが
選択されます。
後は上下左右矢印キーを利用して目的部分に達したらリターンキーを押すと
目的を達成できます。
取り消したい場合は、ＥＳＣキーを押す。
場所によってはダイアログを表示します。
ダイアログ内での、フォーカス移動は、ＴＡＢキーで行います。
後は、矢印キーで選択し、実行はリターンキーを押す。
フォーカスのある所は、点線の四角で囲まれています。
各画面が編集状態の場合は、矢印キーで編集したい部分を選択するか、
マウスの左ボタンで選択できます。
データ入力は、リターンキーを押した場合は、以前の数値が入力ボックスに、
反映されますが、直接数値を入力した場合は、新しい数値が入り、
リターンキーを押すと確定されます。
編集状態でない場合は矢印キーはスクロールバーと連動します。
シフトキーを押しながら、矢印キーを押すとスクロールバーは早く動きます。


エラーについて

「システムに異常が有ります」と「メモリーが足りません」は、お使いの
コンピュータの物理的メモリが足らない場合に表示されます。
プログラムの実行は出来ません。
「ﾃﾞｰﾀ設定ﾌｧｲﾙがない」は、このプログラム Machine.exe が有るフォルダー内に
Machine.ini ファイルが無い場合に表示されます。
加工条件はこのファイルに保存されていますので、全てを設定し直すことになります。
プログラムは、続行出来ますので、加工条件の設定をすると自動的に作成されますので
回復できます。
「ﾃﾞｰﾀ設定ﾌｧｲﾙの長さが違う」、「ﾃﾞｰﾀ設定ﾌｧｲﾙが違う」、「ﾃﾞｰﾀ設定ﾌｧｲﾙが異常」
がでる場合は、何らかの理由で、Machine.ini ファイルが破壊されている場合に表示されます。
プログラムは、続行出来ませんので、Machine.ini ファイルを削除した後、上記の方法を
実行すれば、回復できます。
「加工データファイルが異常、データファイルのサイズが不正です」は、
ファイルの構造が合っていない場合に表示されます。
全てのデータを読み込み中止します。
ファイルを書き直してください。
「加工データファイルではない」は、ファイルの構造がこのプログラムの
ものではない場合に表示されます。
全てのデータを読み込み中止します。
このプログラム用のファイルを選択してください。
「ﾃﾞｰﾀ設定ﾌｧｲﾙ書き込み不良」は、Machine.ini ファイルが読み出し専用に
なっている場合に表示されます。属性を解除してください。
「ﾌﾟﾘﾝﾀｰの異常」は、ErrNo= が 1007 を表示する場合は、ﾌﾟﾘﾝﾀが存在しない
様に見える場合、何らかの異常があります。また、ErrNo= が 000A を表示する場合は、
プリンタードライバーが必要なメモリを確保出来なかった場合に表示されます。
プリンターの設定をし直すと、始めはエラーが出ますが、それを無視しもう一度
プリンターの設定をし直すと、常時使用するプリンターが選択され正常になります。
「縮小拡大印刷には対応していません。」は、プリンターによっては、
Ａ３用紙を選択し実際の用紙はＡ４を使用するような設定が出来るものも有りますが、
このソフトは、対応していませんのではみ出て印刷されてしまいます。
「用紙選択が不適当」は、プリンターによっては、このソフトに登録されていない
用紙番号を返してくるものが有ります。そのときこのエラーが表示されます。


新規データ作成

新規データの作成の為、全てのデータをクリアします。
保存していないデータがある場合は、警告メッセージが出ます。
保存したい場合は、実行を中断し、ファイルの保存をしてから
再度、新規データの作成を実行して下さい。


ファイルを開く

既に保存されているファイルを読み込みます。
入力編集後、保存していないデータがある場合は、
警告メッセージがでます。保存したい場合は、
ファイルを開くを中断し、保存してからファイルを、
読み込んでください。


上書き保存

ファイルを開くで読み込んだファイル、又は一度保存した
ものを再度、保存する場合は、ファイル名が決まっているので、
上書き保存が出来ます。ファイル名が無題になっている場合は、
自動的に新規保存が選択されます。


名前を付けて保存

新規保存、又は読み込んだファイルを別名で、
保存したい場合にここを使います。
既に存在するファイル名を指定した場合は、
警告メッセージが出ます。


加工プログラム出力

翻訳開始

翻訳開始ボタンを押すと翻訳を始めます。

機械語に翻訳した結果を表示します。

ファイル出力

機械語に翻訳した結果をファイルに出力します。
保存ダイアログが表示されますので、ファイル名を入力し、
ＯＫを押してください。拡張子は[TXT]です。
保存先は、プログラムがあるフォルダーと同じフォルダー内の
OutPutDataと言うフォルダーに入りますが、もちろん場所は、

自由に変えても良いです。

印刷

印刷ボタンを押すと表示されているものを印刷します。
印刷用紙はＡ４縦が自動的に設定されます。
リストボックス内の行をクリックすると選択状態になります。
この時、その行が何ページに所属するか表示ページに表示されます。
印刷時に印刷ページ指定が出来ますので、必要な部分のみを印刷する

ことも出来ます。

終了

このウインドウを閉じます。


プリンターの設定

プログラム起動時には、通常使うプリンターが設定
されています。もし、別のプリンターで印刷したい場合は
ここで変更してください。プログラム終了時まで有効です。
設定データは保存されませんので、再度起動した場合は、
通常使うプリンターが設定されています。
[注意]　ここでは、プリンターの選択のみをしてください。
        用紙サイズ、縦横の設定はしないでください。
        印刷時に自動設定されます。


プリンター用フォントの設定

印刷時に使用されるフォントの設定をします。
初期設定は、ＭＳ Ｐゴシック１１ポイントが設定されています。
コンピューターによっては初期設定フォントがインストールされて
ない場合が有り、その時は、印刷できず異常終了します。
フォント設定ダイアログでフォントを設定しても、コンピューター
とプリンターの組み合わせにより、印刷できない場合があることが
判明したため、完全自動でフォント設定をするようにしました。
その為、組み合わせによって、使用されるフォントが違う場合が
あります。


翻訳される部分のみ印刷

加工パターン表印刷をします。
用紙はＡ４横が自動設定されますのでダイアログの
プロパティで変更しないでください。
印刷範囲は、翻訳対象部分のみです。
加工パターン表の初めから、最初の空白部分までです。
印刷中断ダイアログボックスが表示されます
がウインドウズＯＳは２秒に一度しか監視しません。
その為すぐには中断出来ない事が有ります。
印刷ジョブをスプールしている場合は、データ転送速度
が早い為、中断出来ない場合が多いです。
この場合は、印刷ジョブウインドウを呼び出し
そちらで、中止してください。
印刷用紙は一対一の設定にしてください。
縮小拡大印刷には対応していません。


全てを印刷

加工パターン表を印刷をします。
用紙はＡ４横が自動設定されますのでダイアログの
プロパティで変更しないでください。
印刷範囲は、記入されているデータ全てです。
印刷中断ダイアログボックスが表示されますが
ウインドウズＯＳは２秒に一度しか監視しません。
その為すぐには中断出来ない事が有ります。
印刷ジョブをスプールしている場合は、データ転送速度が
早い為、中断出来ない場合が多いです。
この場合は、印刷ジョブウインドウを呼び出し
そちらで、中止してください。
印刷用紙は一対一の設定にしてください。
縮小拡大印刷には対応していません。


ツール番号表印刷

ツール番号表を印刷します。
用紙はＡ４、縦が自動的に設定されます。
印刷ダイアログのプロパティで、用紙、方向を
変更しないでください。
印刷中断ダイアログボックスが表示されます
がウインドウズＯＳは２秒に一度しか監視しません。
その為すぐには中断出来ない事が有ります。
印刷ジョブをスプールしている場合は、データ転送速度が
早い為、中断出来ない場合が多いです。
この場合は、印刷ジョブウインドウを呼び出し
そちらで、中止してください。
印刷用紙は一対一の設定にしてください。
縮小拡大印刷には対応していません。


加工工程表印刷

加工工程表を印刷します。
用紙はＡ４、横が自動的に設定されます。
印刷ダイアログのプロパティで、用紙、方向を
変更しないでください。
印刷中断ダイアログボックスが表示されますが
ウインドウズＯＳは２秒に一度しか監視しません。
その為すぐには中断出来ない事が有ります。
印刷ジョブをスプールしている場合は、データ転送速度
が早い為、中断出来ない場合が多いです。
この場合は、印刷ジョブウインドウを呼び出し
そちらで、中止してください。
印刷用紙は一対一の設定にしてください。
縮小拡大印刷には対応していません。


加工条件表印刷

加工条件表を印刷します。
一枚に２種類、合計５枚印刷されなす。
用紙はＡ４、縦が自動的に設定されます。
印刷ダイアログのプロパティで、用紙、方向を
変更しないでください。
印刷中断ダイアログボックスが表示されますが
ウインドウズＯＳは２秒に一度しか監視しません。
その為すぐには中断出来ない事が有ります。
印刷ジョブをスプールしている場合は、データ転送速度が
早い為、中断出来ない場合が多いです。
この場合は、印刷ジョブウインドウを呼び出し
そちらで、中止してください。
印刷用紙は一対一の設定にしてください。
縮小拡大印刷には対応していません。


パスワードの設定

編集作業時の許可を保護するためのパスワードを、
設定します。


プログラムを終了します

ｱﾌﾟﾘｹｰｼｮﾝの終了

プログラムを終了します。

入力編集後、保存していないデータがある場合は、
警告メッセージがでます。保存したい場合は、終了を
中断し、保存してから終了してください。
システムメニュー（左上のアイコンを右クリックした場合に
表示されるもの、あるいは右上の[＿□×]）の×でプログラム
を終了した場合は警告表示は、出ませんので注意が必要です。


データ入力編集許可

ﾃﾞｰﾀ入力許可

データ入力編集許可

加工パターン表のデータ入力編集を許可します。
パスワードが設定されている場合はパスワードの
入力が必要です。


データ入力編集禁止

ﾃﾞｰﾀ入力許可

データ入力編集禁止

加工パターン表のデータ入力編集を禁止します。


行削除取り消し

編集

行削除取り消し

加工パターン表編集作業で削除された行を復活させます。
一度しか出来ません。


新一行挿入

編集

新一行挿入

加工パターン表の編集作業で空行をカーソル位置に挿入します。


一行削除

編集

一行削除

加工パターン蔑編集作業でカール位置の行を削除します。


一行コピー

編集

一行コピー

加工パターン表の編集作業でカール位置の行をコピーします。
張り付けの為にメモリーに記憶します。


編集

一行張り付け

加工パターン表編集作業でカーソル位置にコピーした行データを、
挿入貼り付けします。


被加工物材質設定

工順及び材質設定

被加工物材質設定

新規データ作成時、最初に設定しなければならない項目です。
材質、座標系、制御装置別翻訳選択、ＯＫ、キャンセル、
自動工作機械別翻訳語の選択をすると、面取りカッターの機種別設定に、
したがって、全てのパターンの面取りカッターが設定されます。
加工パターンの入力時には、各パターンに個別に面取りカッターの設定が出来ます。
各パターンに個別に設定した場合でも、此処で機種選択をやり直すと、
全てが此処で選択した機種に合わせた面取りカッターが設定されます。
板厚設定、プログラム番号には説明が入っています。
それぞれの説明は、マウスカーソルを合わせクリックすると見ることが出来ます。


使用ツール番号設定

工順及び材質設定

使用ツール番号設定

新規の場合は、編集ボタンを押した後、この場合ボタン表示が[表示]に
変わります。次に、ツール検索ボタンを押すと、使用されているツールが
表示されます。表示されたツールの番号を入力してください。
未入力や、重複が有る場合は、終了ボタンを押した時警告が出ます。
ファイルを読み込んだ場合は、保存した段階にもよりますが、
ツール検索後にパターンファイルを保存した場合は、ツール情報も
記録されていますので新たにツール検索をしなくてもツール番号は
表示されます。
加工パターンを編集すると、ツール検索情報はクリアされますので、
ツール検索をし直す必要があります。但し、プログラムを終了しない限り、
設定されたツール番号は覚えていますので、一致するものは自動的に
割り付けられます。
ツール番号自動割り付けは、ツール番号が全て正常に設定された場合、
終了ボタンを押すと、ツール番号データを保存するか尋ねるので、
ここで保存しておいたデータを元に自動番号割り付けを行う事が出来ます。
自動生成ダイアログを使うを選択した場合は、カーソル位置から、
ダイアログで指定した初期値と、行数に連番を設定することが出来ます。
このウインドウを閉じた段階で、作業工程順が作成されます。
ツール検索、ツール番号自動割り付け、編集、終了、Ｄ補正番号、[×]、
スクロールには、説明が入れてありますので参考にしてください。
システムメニュー（左上のアイコンを右クリックした場合に
表示されるもの、あるいは右上の[×]）でウインドウを閉じ
た場合は警告表示は、出ませんので注意が必要です。
但し、処理情報表示ウインドウには、記録されます。
処理情報表示ウインドウは、起動は使用ツール番号設定のツール検索ですが
所有権はメインウインドウが持っていますので、使用ツール番号設定を
閉じても消滅しません。
表示情報の内（×）で表示されているものは、訂正する必要があります。
表示情報の内（！）で表示されているものは、自動処理されたものです。
これを見ながら加工パターンデータの訂正をしてください。


作業工程順表示及び変更

工順及び材質設定

作業工程順表示及び変更

作業工程順表示はツール検索後に作成される、各ツールによる実際の作業内容を表示しています。
ここで、実際に作業を実行すると不都合のある部分を削除、或いは順序を変更できます。
編集ボタンを押し編集モードにすると行の削除入れ替えが出来ます。
一度に操作できる範囲は最大１０行までです。マウスの左ボタンで初めの位置を決め、
そのままボタンを押しながら下方にドラッグすると範囲が広がります。
次に、右クリックをするとフローティングメニューを表示するので操作したい項目を
クリックすると操作できます。尚、操作内容は、最大１００回まで記憶していますので、
元に戻すを押すと、押す度に一つ手前の状態に戻ります。
問題になる部分を解決したら、加工順序最適化ボタンを押すと最も高率的に
作業する並び方に順序を変えます。
自動最適化で問題が起こる場合は、さらに順序の入れ替えが出来ます。
いずれの作業内容も、記録されますので、最初の状態まで戻す事は可能です。
各ボタン、スクロール、システムメニュー、表示画面に説明が入っているので参考にしてください。


面取りカッター選択

面取りカッター設定で、全体設定を行なうとその値がパターンデータファイル保存エリアに記憶される。
ファイルの保存を行なうと、その値がファイルに記録されるので、読み出した時に設定値を引き継げる。
個別設定の値は、リスト番号毎に別々に記録される。
リスト番号は、現在編集対象の行番号、加工法は、編集対象の加工パターンプを表示している。

それぞれの説明は、マウスカーソルを合わせクリックすると見ることが出来ます。


ドリル

加工条件入力

ドリル

ドリルのサイズと加工物の材質による
回転数と送り速度を設定します。
このウインドウの項目切り替えは、メインウインドウの
加工条件入力メニューをクリックする事で変更出来ます。
利点としては、一回事に終了した場合、パスワードが設定
されていると、毎回入力を求められますが、上記の方法では
編集状態のまま切り替えられます。
最後に終了をすれば、全ての変更内容が記録されます。


ザグリエンドミル

加工条件入力

ザグリエンドミル

ザグリエンドミルのサイズと加工物の材質による
回転数と送り速度を設定します。
このウインドウの項目切り替えは、メインウインドウの
加工条件入力メニューをクリックする事で変更出来ます。
利点としては、一回事に終了した場合、パスワードが設定
されていると、毎回入力を求められますが、上記の方法では
編集状態のまま切り替えられます。
最後に終了をすれば、全ての変更内容が記録されます。


タップ

加工条件入力

タップ

標準タップのサイズと加工物の材質による
回転数と送り速度を設定します。
回転数掛けるピッチが送り速度と一致しないと
送り速度部分の入力が出来ないようになっています。
このウインドウの項目切り替えは、メインウインドウの
加工条件入力メニューをクリックする事で変更出来ます。
利点としては、一回事に終了した場合、パスワードが設定
されていると、毎回入力を求められますが、上記の方法では
編集状態のまま切り替えられます。
最後に終了をすれば、全ての変更内容が記録されます。


リーマー

加工条件入力

リーマー

リーマーのサイズと加工物の材質による
回転数と送り速度を設定します。
このウインドウの項目切り替えは、メインウインドウの
加工条件入力メニューをクリックする事で変更出来ます。
利点としては、一回事に終了した場合、パスワードが設定
されていると、毎回入力を求められますが、上記の方法では
編集状態のまま切り替えられます。
最後に終了をすれば、全ての変更内容が記録されます。


Ｈ７穴エンドミル

加工条件入力

Ｈ７穴エンドミル

Ｈ７穴エンドミルのサイズと加工物の材質による
回転数と送り速度を設定します。
このウインドウの項目切り替えは、メインウインドウの
加工条件入力メニューをクリックする事で変更出来ます。
利点としては、一回事に終了した場合、パスワードが設定
されていると、毎回入力を求められますが、上記の方法では
編集状態のまま切り替えられます。
最後に終了をすれば、全ての変更内容が記録されます。


荒削りエンドミル

加工条件入力

荒削りエンドミル

荒削りエンドミルのサイズと加工物の材質による
回転数と送り速度を設定します。
このウインドウの項目切り替えは、メインウインドウの
加工条件入力メニューをクリックする事で変更出来ます。
利点としては、一回事に終了した場合、パスワードが設定
されていると、毎回入力を求められますが、上記の方法では
編集状態のまま切り替えられます。
最後に終了をすれば、全ての変更内容が記録されます。


仕上げエンドミル

加工条件入力

仕上げエンドミル

仕上げエンドミルのサイズと加工物の材質による
回転数と送り速度を設定します。
このウインドウの項目切り替えは、メインウインドウの
加工条件入力メニューをクリックする事で変更出来ます。
利点としては、一回事に終了した場合、パスワードが設定
されていると、毎回入力を求められますが、上記の方法では
編集状態のまま切り替えられます。
最後に終了をすれば、全ての変更内容が記録されます。


ボーリング

加工条件入力

ボーリング

ボーリングのサイズと加工物の材質による
回転数と送り速度を設定します。
このウインドウの項目切り替えは、メインウインドウの
加工条件入力メニューをクリックする事で変更出来ます。
利点としては、一回ごとに終了した場合、パスワードが設定
されていると、毎回入力を求められますが、上記の方法では
編集状態のまま切り替えられます。
最後に終了をすれば、全ての変更内容が記録されます。


フェースミル

加工条件入力

フェースミル

フェースミルのサイズと加工物の材質による
回転数と送り速度を設定します。
このウインドウの項目切り替えは、メインウインドウの
加工条件入力メニューをクリックする事で変更出来ます。
利点としては、一回事に終了した場合、パスワードが設定
されていると、毎回入力を求められますが、上記の方法では
編集状態のまま切り替えられます。
最後に終了をすれば、全ての変更内容が記録されます。


下穴エンドミル

加工条件入力

下穴エンドミル

下穴エンドミルのサイズと加工物の材質による
回転数と送り速度を設定します。
このウインドウの項目切り替えは、メインウインドウの
加工条件入力メニューをクリックする事で変更出来ます。
利点としては、一回事に終了した場合、パスワードが設定
されていると、毎回入力を求められますが、上記の方法では
編集状態のまま切り替えられます。
最後に終了をすれば、全ての変更内容が記録されます。


面取りカッター

面取りカッターの仕様を設定する。Mentori01は、仕様が固定されているので編集は出来ない。
残り９種類は、刃物径、回転数、横速度、Ｚ速度、深さ、補正番号、サブ番号を設定出来る。
リスト上で編集したい番号をクリックして選択状態にしたら、編集ボタンを押して編集可にする。
それぞれの項目に数値を入力しても、リスト上の数値は変化しないので、表示更新ボタンを押すと
数値が反映される。但し、表示更新をしなくても、設定値は、変わっている。

「注意」面取りカッター工具の種類は、刃物径に拠って決まる。
刃物径が同じ場合は、同じ工具と認識されるので、ツール番号も同じになる。
但し、回転数等のパラメータは、選択したものの値が設定される。

それぞれの説明は、マウスカーソルを合わせクリックすると見ることが出来ます。


機種別エンドミル速度その他設定

面取りカッター、荒、仕上げエンドミルの速度等を設定する。

始に自動工作機械の機種を選択する。
全部で９種類の機種の加工条件を設定出来る。

設定値を変更したい場合には、編集ボタンを押して編集可にする。

面取りカッター選択は、予め、面取りカッター設定で設定した
条件を機種毎に選択する為の設定である。
此処で設定された情報は、材質や板厚を設定する場所で、
翻訳機種を選択すると、自動的に全てのパターンに設定される。
加工パターン設定では、個別設定も出来るが、翻訳機種を選択を、。
やり直すと、個別設定された部分も、此処で設定した内容に変更される。

荒エンドミルの深さ回数時の送り速度を設定する。深さ回数が０か１の場合は使われない。
荒エンドミルの手前の送り速度を設定する。
最終加工深さを設定する。最終工程で残す深さを設定する。
最終送り速度を設定する。最終工程での送り速度を設定する。
サブ番号を設定する。円弧補間時のサブプログラム番号を設定する。

仕上エンドミルの深さ回数時の送り速度を設定する。深さ回数が０か１の場合は使われない。
仕上げエンドミルの手前の送り速度を設定する。
最終送り速度を設定する。最終工程での送り速度を設定する。
サブ番号を設定する。円弧補間時のサブプログラム番号を設定する。

設定値を変更した場合には、設定保存を押して数値を記憶させる。
それぞれの説明は、マウスカーソルを合わせクリックすると見ることが出来ます。


ヘルプ

このヘルプを表示します。
ヘルプを表示後それを閉じると、キーの入力フォーカスが
メインウインドウに移ってしまいます。
他の画面を操作している場合、一時的に操作不能になる場合が有ります。
そのときは、マウスを表示画面上に置いて左クリックをすると、
フォーカスが戻ります。


バージョン情報

このプログラムのバージョン情報を表示します。


座標系数値設定

G54,G55,G56,G57 座標系オフセット設定
座標系のオフセット値を入力するダイアログボックス。
現時点のプログラムでは、数値を使っている所は有りません。
将来バージョンアップした時、加工座標の入ったサブファイルと
連携し、座標系を変更した場合、自動的に座標オフセットを実行
出来る様にする為のものです。